<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-CA" class="no-js"> <!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.habsworld.net/xmlrpc.php">
<link href='http://fonts.googleapis.com/css?family=Open+Sans+Condensed:700' rel='stylesheet' type='text/css'>
<link rel="stylesheet" href="http://www.habsworld.net/wp-content/themes/habsworld/css/bootstrap.min.css">
<link rel="stylesheet" href="http://www.habsworld.net/wp-content/themes/habsworld/css/bootstrap-theme.min.css">
<link rel="stylesheet" href="http://www.habsworld.net/wp-content/themes/habsworld/style.css">
<!--[if lt IE 9]>
            <script src="http://www.habsworld.net/wp-content/themes/habsworld/js/vendor/html5-3.6-respond-1.1.0.min.js"></script>
        <![endif]-->
<title>Chill Out Already:  Price Will be Fine | HabsWorld.net</title>
<link rel="alternate" type="application/rss+xml" title="HabsWorld.net &raquo; Feed" href="http://www.habsworld.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="HabsWorld.net &raquo; Comments Feed" href="http://www.habsworld.net/comments/feed/" />
<link rel='stylesheet' id='wp-polls-css' href='http://www.habsworld.net/wp-content/plugins/wp-polls/polls-css.css?ver=2.72' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://www.habsworld.net/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='genericons-css' href='http://www.habsworld.net/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='http://www.habsworld.net/wp-content/plugins/jetpack/css/jetpack.css?ver=3.5.3' type='text/css' media='all' />
<script type='text/javascript' src='http://www.habsworld.net/wp-includes/js/jquery/jquery.js?ver=1.11.1'></script>
<script type='text/javascript' src='http://www.habsworld.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.habsworld.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.habsworld.net/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='An Ugly, Ugly Loss to Coyotes' href='http://www.habsworld.net/2017/11/an-ugly-ugly-loss-to-coyotes/' />
<meta name="generator" content="WordPress 4.1.20" />
<link rel='canonical' href='http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/' />
<link rel='shortlink' href='http://wp.me/p5K7y3-eej' />
<style type='text/css'>img#wpstats{display:none}</style>

<meta property="og:type" content="article" />
<meta property="og:title" content="Chill Out Already:  Price Will be Fine" />
<meta property="og:url" content="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/" />
<meta property="og:description" content="Some fans and writers have been quick to malign Carey Price after some early struggles and Charlie Lindgren&#039;s hot start.  However, it&#039;s far too early to write him off just yet. " />
<meta property="article:published_time" content="2017-11-18T02:47:46+00:00" />
<meta property="article:modified_time" content="2017-11-18T02:47:46+00:00" />
<meta property="article:author" content="http://www.habsworld.net/author/dave-woodward/" />
<meta property="og:site_name" content="HabsWorld.net" />
<meta property="og:image" content="http://www.habsworld.net/wp-content/uploads/2017/08/cut.jpg" />
<meta name="twitter:site" content="@habsworld_net" />
<meta name="twitter:image:src" content="http://www.habsworld.net/wp-content/uploads/2017/08/cut.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@habsworld_net" />
</head>
<body class="single single-post postid-54703 single-format-standard">
<!--[if lt IE 7]>
            <p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.</p>
        <![endif]-->
<div class="container">
<div class="row"><div class="col-sm-12" id="bg"></div></div>
</div>
<div class="navbar navbar-default" role="navigation">
<div class="container">
<div class="navbar-header">
<a class="navbar-brand" href="http://www.habsworld.net/"><span class="hide-text">HabsWorld.net</span></a>
</div>
<div class="navbar-collapse collapse">
<ul class="nav navbar-nav navbar-right hidden-sm">
<li class="navbar-text" style="margin-top:36px; text-align:right">
World Wide Habs Fans Community <p style="margin-top:10px"><a href="http://forums.habsworld.net" class="btn btn-primary" role="button">Community Forums</a></p>
</li>
</ul>
</div>
</div>
</div>
<div class="container page-container">
<div class="row">
<div class="col-md-6 col-sm-8 col-md-push-3 col-md-push-4" style="z-index:9;">
<div id="post-54703" class="post-54703 post type-post status-publish format-standard has-post-thumbnail hentry category-big-news category-habs">
<h2 class="page-title" style="margin-top:0">Chill Out Already: Price Will be Fine</h2>
<h5 style="font-weight:normal">
<span class="byline"><span class="author vcard"><span class="screen-reader-text">By </span><a class="url fn n" href="http://www.habsworld.net/author/dave-woodward/">Dave Woodward</a></span></span> &ndash; <span class="posted-on"><a href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/" rel="bookmark"><time class="entry-date published updated" datetime="2017-11-17T21:47:46+00:00">November 17, 2017</time></a></span> </h5>


<p class="hidden-print"><img width="1024" height="576" src="http://www.habsworld.net/wp-content/uploads/2017/08/cut.jpg" class="img-responsive wp-post-image" alt="Carey" /></p>
<div class="article-text">
<p class="pull-left" style="margin:0;">HabsWorld.net --&nbsp;</p>
<p>The Canadiens’ horrendous 1-6-1 start was due to many factors. A chronic ability to score, untimely defensive breakdowns &#8211; with new personnel adjusting to a new system and one another &#8211; and hapless special teams play all contributed to the team’s worst start since World War II. However, the key factor was the unexpectedly poor play of Carey Price.</p>
<p>While it is undeniable that Price’s start has been very subpar, this pundit has read with dismay some of the press clippings over the past few weeks such as:</p>
<p>Contract makes Carey Price Tough to Trade<br />
Canadiens Crease Crisis as Carey Price Mystery Deepens<br />
Canadiens Longing for Real Carey Price as Margin for Error Narrows</p>
<p>With the fine recent play of Charlie Lindgren, reporters have opined that, “There is a full blown goaltending controversy in Montreal with Minnesota kid Charlie Lindgren giving Carey Price a run for his money”.</p>
<p>While overreactions go with the territory in Montreal, a little perspective is in order. A good place to start is a fulsome review of what the suddenly dispensable Carey Price has delivered over his career and in the past four years in particular. Price’s career numbers are outstanding for a goaltender that has played on some pretty ordinary teams (520 GP, 273W, 182L, 56T, 39SO, 2.43GAA, .919SV%). For the last four years, his performance has been nothing short of legendary (2013-14: 2.32GAA, .927SV%; 2014-15: 1.96GAA, .933SV%; 2015-16: 2.06GAA, .934SV%; 2016-17: 2.23GAA, .923SV%).</p>
<p>Price’s numbers are Hall of Fame calibre.  For the last several years, Carey Price has not only been their best player but has been one of the only players that have separated the Canadiens from some of the most mediocre teams in the NHL. His 2015-16 injury proved just that.  The knock on Price has been his failure to lead the Habs to the promised land and raise No. 25 to the rafters.  Have the Canadiens been good enough to even contend for the Cup the last several years?  Compare the personnel of the 1986 and 1993 teams to the Habs&#8217; most recent rosters and the answer is clear.  Of course not.</p>
<p>When one reads the recent headlines, it seems that Price’s ten-game slump and recent minor injury have ended his career and Lindgren is now the last best hope for the Canadiens. Lindgren is a fine prospect and has certainly filled in admirably in Price’s absence. And the Canadiens’ history includes legendary performances by young goaltenders who have come out of nowhere to lead the Habs to glory. This pundit became a lifelong Canadiens fan courtesy of Ken Dryden’s incredible Conn Smythe run in 1971. Patrick Roy’s unexpected and outstanding 1986 Conn Smythe performance is a more contemporary example. However, Lindgren is 3-2-1 in this regular season (albeit with some impressive early season games). It remains to be seen whether Charlie Lindgren is more Dryden/Roy than Steve Penney/Wayne Thomas. Meanwhile, the entire Montreal media is dismissing the best goalie in the NHL for the past five years and anointing an unproven, but promising, AHL goalie as the team&#8217;s new number one.</p>
<p>One cannot imagine what it must be like to play in Montreal. Or more to the point, one cannot imagine why an elite player with options would want to do so after the recent media coverage and internet commentary on Carey Price. This sort of treatment of an athlete who has long outperformed his peers by any measure is simply wrong. By doing so, Habs Nation is relegating the team to mediocrity. No one with options will want to sign in Montreal.</p>
<p>To borrow a phrase, everyone should just chill, give Carey some space and let him do his thing. Carey Price will be just fine. I&#8217;m not so sure about the Canadiens, however.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-54703" class="share-facebook sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-54703" class="share-twitter sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-54703" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-54703" class="share-linkedin sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-stumbleupon"><a rel="nofollow" data-shared="" class="share-stumbleupon sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=stumbleupon" target="_blank" title="Click to share on StumbleUpon"><span></span><span class="sharing-screen-reader-text">Click to share on StumbleUpon (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-54703" class="share-pinterest sd-button share-icon no-text" href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>
</div>
</div>
<br />
<div class="row hidden-print"><div class="col-xs-6 featured">
<a href="http://www.habsworld.net/2017/11/an-ugly-ugly-loss-to-coyotes/">
<img src="http://www.habsworld.net/wp-content/uploads/2017/11/Coyotes-Habs.jpg" class="img-responsive" style="width:100%; border:1px solid #000" />
<div>
<h4>An Ugly, Ugly Loss to Coyotes</h4>
<p>
Montreal's defencemen all appeared to have lead anchoring their skates to the ice as they allowed five goals and many more opportunities in a 5-4 loss to the Coyotes on Thursday night. <span class="pull-right" style="font-size:90%; padding-top:2px">Read More »</span>
</p>
</div>
</a>
</div>
<div class="col-xs-6 featured">
<a href="http://www.habsworld.net/2017/11/habs-drop-goaltending-duel-to-jackets/">
<img src="http://www.habsworld.net/wp-content/uploads/2017/11/Habs-Columbus.jpg" class="img-responsive" style="width:100%; border:1px solid #000" />
<div>
<h4>Habs Drop Goaltending Duel to Jackets</h4>
<p>
Sergei Bobrovsky is the reigning Vezina Trophy winner, and he was in full form on Tuesday as the Blue Jackets were able to steal two points from a determined Charlie Lindgren and his Canadiens in a 2-1 overtime contest. <span class="pull-right" style="font-size:90%; padding-top:2px">Read More »</span>
</p>
</div>
</a>
</div>
</div>
</div>
<div class="col-md-3 col-sm-4 hidden-print col-md-pull-6 col-sm-pull-8 hidden-sm">
<aside id="recent-posts-3" class="widget widget_recent_entries"> <h3 class="widget-title">Latest Articles</h3> <ul class="list-group list-group-compact" style="font-size:95%">
<li class="list-group-item">
<a href="http://www.habsworld.net/2017/11/chill-out-already-price-will-be-fine/">
<span class="clip">Chill Out Already: Price Will be Fine</span>
<span class="post-date text-muted" style="display:block">November 17, 2017</span>
</a>
</li>
<li class="list-group-item">
<a href="http://www.habsworld.net/2017/11/an-ugly-ugly-loss-to-coyotes/">
<span class="clip">An Ugly, Ugly Loss to Coyotes</span>
<span class="post-date text-muted" style="display:block">November 16, 2017</span>
</a>
</li>
<li class="list-group-item">
<a href="http://www.habsworld.net/2017/11/habs-drop-goaltending-duel-to-jackets/">
<span class="clip">Habs Drop Goaltending Duel to Jackets</span>
<span class="post-date text-muted" style="display:block">November 14, 2017</span>
</a>
</li>
<li class="list-group-item">
<a href="http://www.habsworld.net/2017/11/little-need-to-worry-with-niemi/">
<span class="clip">Little Need to Worry With Niemi</span>
<span class="post-date text-muted" style="display:block">November 14, 2017</span>
</a>
</li>
<li class="list-group-item">
<a href="http://www.habsworld.net/2017/11/hw-3-stars-october/">
<span class="clip">HW 3 Stars: October 2017</span>
<span class="post-date text-muted" style="display:block">November 14, 2017</span>
</a>
</li>
</ul>
</aside><aside id="search-3" class="widget widget_search"><form role="search" method="get" id="searchform" action="http://www.habsworld.net/">
<div class="input-group">
<input type="search" class="form-control" placeholder="Search Articles..." name="s" />
<div class="input-group-btn">
<input type="submit" class="btn btn-primary" value="Search" />
</div>
</div>
</form></aside> <aside id="forum-activity-3" class="widget widget_forum_activity"> <h3 class="widget-title">Latest Forum Activity</h3> <ul class="list-group list-group-compact" style="font-size:95%">
</ul>
<p><a href="http://forums.habsworld.net" class="btn btn-primary" style="display:block" role="button">Community Forums</a></p>
</aside> </div>
<div class="col-md-3 hidden-print">
<aside id="hw-google-ad-4" class="widget widget_hw_google_ad">
<script type="text/javascript"><!--
	google_ad_client = "ca-pub-2780345194772535";
	google_ad_slot = "1204883556";
	google_ad_width = 300;
	google_ad_height = 250;
	//-->
</script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script>
</aside> <aside id="hw-google-ad-5" class="widget widget_hw_google_ad">
<script type="text/javascript"><!--
	google_ad_client = "ca-pub-2780345194772535";
	google_ad_slot = "1204883556";
	google_ad_width = 300;
	google_ad_height = 250;
	//-->
</script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script>
</aside> </div>
</div>
<div class="row hidden-print">
<div class="col-md-12" style="margin-top:10px; text-align:center">
<script type="text/javascript"><!--
google_ad_client = "ca-pub-2780345194772535";
/* homepage */
google_ad_slot = "0275949830";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script>
</div>
</div>
<footer>
<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-64" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-64"><a>© HabsWorld.net 2017</a></li>
<li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-79"><a href="http://www.habsworld.net/">Home</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="http://www.habsworld.net/about/">About</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48"><a href="http://forums.habsworld.net">Forums</a></li>
<li id="menu-item-62" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62"><a>|</a></li>
<li id="menu-item-49" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49"><a href="http://www.habsworld.net/category/habs/">Habs</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="http://www.habsworld.net/category/prospects/">Prospects</a></li>
<li id="menu-item-51" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51"><a href="http://www.habsworld.net/category/more-coverage/">More</a></li>
<li id="menu-item-63" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-63"><a>|</a></li>
<li id="menu-item-37180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37180"><a href="http://www.habsworld.net/links/">Links</a></li>
<li id="menu-item-37185" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37185"><a href="http://www.habsworld.net/author/podcast/">Podcast</a></li>
<li id="menu-item-53" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53"><a href="https://www.facebook.com/habsworld.net">Facebook</a></li>
<li id="menu-item-52" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52"><a href="https://twitter.com/habsworld_net">Twitter</a></li>
<li id="menu-item-67" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-67"><a>|</a></li>
<li id="menu-item-66" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66"><a href="/wp-admin">HW Login</a></li>
</ul></div> </footer>
</div>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>
<script>window.jQuery || document.write('<script src="http://www.habsworld.net/wp-content/themes/habsworld/js/vendor/jquery-1.11.1.min.js"><\/script>')</script>
<script src="http://www.habsworld.net/wp-content/themes/habsworld/js/vendor/bootstrap.min.js"></script>
<script src="http://www.habsworld.net/wp-content/themes/habsworld/js/main.js"></script>

<script>
			(function(b,o,i,l,e,r){b.GoogleAnalyticsObject=l;b[l]||(b[l]=
			function(){(b[l].q=b[l].q||[]).push(arguments)});b[l].l=+new Date;
			e=o.createElement(i);r=o.getElementsByTagName(i)[0];
			e.src='//www.google-analytics.com/analytics.js';
			r.parentNode.insertBefore(e,r)}(window,document,'script','ga'));
			ga('create','UA-145486-8');ga('send','pageview');
		</script>
<div style="display:none">
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.habsworld.net\/2017\/11\/chill-out-already-price-will-be-fine\/":54703};
		window.WPCOM_jetpack = true;
				window.WPCOM_site_ID = 84873787;
			</script>
<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
<div id="sharing_email" style="display: none;">
<form action="/2017/11/chill-out-already-price-will-be-fine/" method="post">
<label for="target_email">Send to Email Address</label>
<input type="email" name="target_email" id="target_email" value="" />
<label for="source_name">Your Name</label>
<input type="text" name="source_name" id="source_name" value="" />
<label for="source_email">Your Email Address</label>
<input type="email" name="source_email" id="source_email" value="" />
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
<img style="float: right; display: none" class="loading" src="http://www.habsworld.net/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
<input type="submit" value="Send Email" class="sharing_send" />
<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>
<div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses! </div>
<div class="errors errors-2" style="display: none;">
Email check failed, please try again </div>
<div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email. </div>
</form>
</div>
<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-tumblr' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
		});
		</script>
<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-pocket' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
		});
		</script>
<script type="text/javascript">
			jQuery(document).on('ready', function(){
				jQuery('body').on('click', 'a.share-pinterest', function(e){
					e.preventDefault();

					// Load Pinterest Bookmarklet code
					var s = document.createElement("script");
					s.type = "text/javascript";
					s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
					var x = document.getElementsByTagName("script")[0];
					x.parentNode.insertBefore(s, x);

					// Trigger Stats
					var s = document.createElement("script");
					s.type = "text/javascript";
					s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
					var x = document.getElementsByTagName("script")[0];
					x.parentNode.insertBefore(s, x);
				});
			});
			</script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/www.habsworld.net\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.habsworld.net/wp-content/plugins/wp-polls/polls-js.js?ver=2.72'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201746'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Novaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.habsworld.net/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.1.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.habsworld.net/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=3.5.3'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201746.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:3.5.3',blog:'84873787',post:'54703',tz:'-5',srv:'www.habsworld.net'} ]);
	_stq.push([ 'clickTrackerInit', '84873787', '54703' ]);
</script>
</body>
</html>